Waterford - Multiple Sites - Down 2285563

Incident Report for WiscNet

Postmortem

GLS Network Outage

Posted Sep 02, 2026 - 08:51 CDT

Resolved

Hello,

All sites restored by 3:30 AM and we observe traffic drop facing the provider. At this time no action is needed and we will close out the status page.

Kind regards,
WISC NET
Posted Sep 02, 2026 - 08:51 CDT

Investigating

We've detected an outage on your service starting around 11:05PM. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920.
Posted Sep 01, 2026 - 23:30 CDT
This incident affected: TEACH - Milwaukee (Waterford Graded J1 School District, Waterford UHS School District).