We are continuing our investigations with our local provider. There is no ETR yet at this time.
Posted Apr 01, 2026 - 15:08 CDT
Update
Hello,
We are continuing our investigations with our local provider. There is no ETR yet at this time.
Posted Mar 31, 2026 - 10:37 CDT
Identified
It was discovered that unknown building work occurred in Madison and WiscNet services were impacted. The WiscNet engineering team is engaged and corresponding with teams to coordinate a temporary repair or to move the circuit to a different path, but services are expected to remain down overnight.
We will continue to provide updates as they become available. Next update expected early tomorrow morning during business hours.
Posted Mar 30, 2026 - 20:26 CDT
Update
We're continuing to investigate the issue further. We'll continue to provide updates as we know more.
Posted Mar 30, 2026 - 15:22 CDT
Update
We've opened a ticket with our last mile provider for further investigation. We will continue to provide updates as we know more.
Posted Mar 30, 2026 - 13:56 CDT
Update
Good afternoon,
Both sites are currently up via a redundant link, however we are still working to investigate the outage impacting the primary link.
Posted Mar 30, 2026 - 12:53 CDT
Investigating
Good afternoon,
At 12:05PM CDT we began experiencing an outage impacting one of our core devices. We're currently investigating the issue further.
Posted Mar 30, 2026 - 12:29 CDT
This incident affects: TEACH - Milwaukee (Concordia University, Nicolet UHS School District).