2239943 | Kiel Area School District down

Incident Report for WiscNet

Postmortem

The school district device restored.

Posted May 22, 2026 - 10:00 CDT

Resolved

Hello,

At this time we are seeing all services restored.

Please reach out with any questions.

Thank you,
Posted May 22, 2026 - 04:54 CDT

Investigating

Hello,

Starting at 1:15 am we observed a loss of connection to our on site device for your circuit.

At this time we are requesting onsite power and equipment verification.

Due to a policy change within GLS we are unable to open a ticket on your behave. You can contact them at 1.866.558.1920 and use your site ID of 772 to open a ticket or give us consent to open a ticket on your behalf.

Please reach out with any questions.

Thank you,
Posted May 22, 2026 - 01:25 CDT
This incident affected: TEACH - Milwaukee (Kiel Area School District).