We are observing our alarms for Rosholt School District cleared at 12:49PM CDT 4/3/2026. Upon further investigation, outage was due to power. We will continue to monitor as normal.
Please reach out to the WiscNet NOC for an questions.
Posted Apr 03, 2026 - 20:35 CDT
Update
There continues to be widespread power outages impacting the local area. We are continuing to monitor sites and power events in the local area for restoration. If you have any further questions do not hesitate to reach out.
Posted Apr 03, 2026 - 11:08 CDT
Investigating
The WiscNet NOC has lost access to our device for Rosholt School District again at 4:07 PM CDT. Please verify power to your site and the network equipment. If you are not aware of any internal work occurring and believe this is a network event, please contact GLS Tech Support for 24x7/outages/incidents at 866-558-1920. The TEACH ID for this circuit is 1464.
If you have any additional questions, please contact WiscNet NOC.
Posted Apr 02, 2026 - 16:39 CDT
This incident affected: TEACH - Madison (Rosholt School District).