outage - Wisconsin Heights School District - Down

Incident Report for WiscNet

Resolved

This incident has been resolved.
Posted May 22, 2026 - 04:02 CDT

Investigating

We are currently investigating. GLS has requested the customer open a ticket with them directly. While we investigate are you able to verify connectivity to the equipment and power? Thank you
Posted May 22, 2026 - 01:00 CDT
This incident affected: TEACH - Madison (Wisconsin Heights School District).